Installation Error of Invenio RDM in local machine, please solve

I am facing errors when installing Invenio RDM software in my local machine. The OS is Ubuntu 20.04 LTS. I have attached the screenshot of the error, please see and provide me the solution.

It feels like that the error is related to this, have a look if it helps.

Feel free to join our chat, and ask there: there might be other users encountering the same issue and they can help.

Hi all,

Actually this error is a different one than suggested by nitarocc

It is related to the Docker Version as indicated here. However, it is marked as closed, but I also face the error still on my Ubuntu Machine.

I was able to trace this bug down and it seems that the code is incompatible to my system.
In the file: ./python3.9/site-packages/invenio_cli/helpers/, there is a system call created which is **docker compose version**. However, when I run this manually on the shell, I get: docker: 'compose' is not a docker command.. So I changed the code to docker-compose version, which works then.

To do that, I would recommend to just edit this file and change in the init-method of docker_helper, the line:
self.docker_compose = ["docker", "compose"]
self.docker_compose = ["docker-compose"]

Then it works. I will report this in the Github Issues.

What Docker version are you using? You should have the versions specified here in the doc.
docker-compose was removed in recent version of Docker.

My version is:
docker -v
Docker version 24.0.5, build 24.0.5-0ubuntu1~20.04.1
So it fits to the requirement, right?

Here is docker-compose for reference:
docker-compose -v
docker-compose version 1.25.0, build unknown

Can you also share the version of invenio-cli? Make sure that you have the latest.

Please find the attachment, the versions are mentioned.

I applied the same, but the same result happened.

But what happens, if you type docker compose version? This is exactly what the program does internally.

**Please see the commands I have used to Install Invenio and see the errors. Kindly suggest me what to do next or share with me the complete manual of every steps to install Invenio latest version in my local machine of Ubuntu 20.04 LTS.
(As I am the new user, I have the right to post of teo URLs, so rest of the URL I broke to avoid, please take all the URLs of the post as original)

Documentation URL- System requirements - Turn-key research data management repository


43 git clone GitHub - ImageMagick/ImageMagick: 🧙‍♂️ ImageMagick 7 ImageMagick-7.1.1
44 cd ImageMagick-7.1.1
45 ./configure
46 make
47 ./configure --with-modules
48 sudo make install
49 sudo ldconfig /usr/local/lib
50 /usr/local/bin/convert logo: logo.gif
51 history


iimc@iimc-ThinkCentre-M70s:~$ history
1 sudo apt-get update
2 sudo apt-get upgrade
3 sudo apt-get update
4 sudo apt-get upgrade
5 ls
6 rpm -Uvh ImageMagick-7.1.1-28.x86_64.rpm
7 sudo apt install rpm
8 rpm -Uvh ImageMagick-7.1.1-28.x86_64.rpm
9 rpm -Uvh epel-release-latest-9.noarch.rpm
10 sudo apt install alien
11 udo alien -i ImageMagick-7.1.1-28.x86_64.rpm
12 sudo alien -i ImageMagick-7.1.1-28.x86_64.rpm
13 sudo apt install -f
14 convert --version
15 dpkg -l | grep imagemagick
16 sudo updatedb
17 sudo update db
18 sudo update locate
19 locate
20 sudo apt reinstall imagemagick
21 convert --version
22 sudo alien -i ImageMagick-7.1.1-28.x86_64.rpm
23 sudo apt install -f
24 convert --version
25 ls
26 sudo chmod 777 ImageMagick-7.1.1-28.x86_64.rpm -R
27 ls
28 sudo dpkg -i ImageMagick-7.1.1-28.x86_64.rpm
29 sudo apt install rpm2cpio cpio
30 rpm2cpio ImageMagick-7.1.1-28.x86_64.rpm | cpio -idmv
31 sudo cp -r usr/bin/* /usr/bin/
32 sudo cp -r usr/lib/* /usr/lib/
33 sudo cp -r usr/share/* /usr/share/
34 convert --version
35 ls usr/share/
36 sudo cp -r usr/share/man/* /usr/share/man/
37 sudo cp -r usr/share/doc/* /usr/share/doc/
38 convert --version
39 sudo apt purge imagemagick
40 sudo apt autoremove
41 convert --version
42 exit
43 git clone https:// github. com/ImageMagick /ImageMagick .git ImageMagick-7.1.1
44 cd ImageMagick-7.1.1
45 ./configure
46 make
47 ./configure --with-modules
48 sudo make install
49 sudo ldconfig /usr/local/lib
50 /usr/local/bin/convert logo: logo.gif
51 history
52 convert --version
53 exit
54 sudo apt update
55 sudo apt install software-properties-common
56 sudo add-apt-repository ppa:deadsnakes/ppa
57 sudo apt install python3.9
58 python3.9 --version
59 python -m ensurepip
60 python3 -m ensurepip
61 sudo apt-get install python3-pip python3-dev
62 Docker 20.10.10+.
63 Docker 20.10.10+
64 Docker 20.10.10+ install
65 sudo apt-get install Docker 20.10.10+
66 install Docker 20.10.10+
67 install Docker 20.10.10
68 Docker 20.10.10
69 docker 20.10.10
70 sudo apt install docker. io # version 24.0.5-0ubuntu1~20.04.1
71 docker-Compose 1.17.0+
72 docker-Compose 1.17.0
73 Docker-Compose 1.17.0
74 install docker-Compose 1.17.0
75 docker-Compose 1.17.0
76 docker-Compose 1.17
77 docker Compose 1.17.0+
78 docker --help
79 Docker-Compose 1.17.0+
80 Docker-Compose 1.17.0
81 docker-Compose 1.17.0
82 sudo docker-Compose 1.17.0
83 install docker-Compose 1.17.0
84 install docker-Compose 1.17
85 docker-Compose 1.17
86 docker-compose 1.17.0+
87 sudo apt install docker-compose # version 1.25.0-1
88 add-apt-repository ppa:git-core/ppa
89 sudo add-apt-repository ppa:git-core/ppa
90 sudo apt update
91 sudo apt install git
92 nvm install --lts --default 14
93 sudo nvm install --lts --default 14
94 gh repo clone nvm-sh/nvm
95 nvm
96 nvm default
97 nvm install --lts
98 wget -qO- https:// raw.githubusercontent. com /nvm-sh/nvm/v0.39.1/ | bash
99 source ~/.bashrc
100 nvm -v
101 nvm install --lts --default 14
102 node -v
103 npm -v
104 pip install invenio-formatter
105 pip install invenio-formatter[badges]
106 sudo apt-get install libcairo2-dev
107 sudo apt-get update
108 .sudo apt-get install fonts-dejavu
109 sudo apt-get install fonts-dejavu
110 sudo apt-get install -y fonts-dejavu-core
111 history
112 sudo apt-get update
113 wget --quiet -O – https:// www .postgresql. org/media/keys/ACCC4CF8.asc | sudo apt-key add -
114 echo “deb http: //apt. postgresql. org/pub/repos/apt/ $(lsb_release -cs)-pgdg main” | sudo tee /etc/apt/sources.list.d/postgresql-pgdg.list > /dev/null
115 sudo echo “deb http: //apt. postgresql. org/pub/repos/apt/ $(lsb_release -cs)-pgdg main” | sudo tee /etc/apt/sources.list.d/postgresql-pgdg.list > /dev/null
116 echo “deb http ://apt .postgresql. org/pub/repos/apt/ $(lsb_release -cs)-pgdg main” | sudo tee /etc/apt/sources.list.d/postgresql-pgdg.list > /dev/null
117 echo “deb http: //apt. postgresql. org/pub/repos/apt/ $(lsb_release -cs)-pgdg main” | sudo tee /etc/apt/sources.list.d/postgresql-pgdg.list >
118 echo “deb http: //apt .postgresql. org/pub/repos/apt/ $(lsb_release -cs)-pgdg main” | sudo tee /etc/apt/sources.list.d/postgresql-pgdg.list &gt
119 sudo echo “deb http: //apt .postgresql. org/pub/repos/apt/ $(lsb_release -cs)-pgdg main” | sudo tee /etc/apt/sources.list.d/postgresql-pgdg.list > /dev/null
120 sudo apt-get update
121 sudo apt-get install postgresql-10
122 sudo service postgresql status
123 sudo systemctl restart postgresql
124 sudo su - postgres
125 sudo apt update && sudo apt upgrade -y
126 sudo apt -y install curl lsb-release gnupg2 ca-certificates
127 echo “deb https :// bundle/opensearch/ 2.x/apt stable main” | sudo tee /etc/apt/sources.list.d/opensearch- 2.x.list
128 sudo apt update
129 sudo apt list -a opensearch
130 sudo apt install opensearch=2.12
131 sudo apt install opensearch
132 sudo apt install opensearch=2.12.0
133 sudo apt install opensearch=2.0
134 sudo apt install opensearch=2.0.0
135 sudo apt install opensearch-2.0.0.
136 sudo apt install opensearch-2.0.0
137 sudo apt install opensearch=2.10.0
138 sudo snap install opensearch
139 sudo systemctl restart opensearch
140 sudo systemctl enable --now opensearch
141 systemctl status opensearch
142 snap list
143 sudo snap restart opensearch
144 sudo snap services
145 sudo snap start opensearch
146 sudo snap services
147 sudo apt install memcached
148 sudo apt install redis-server
149 sudo apt install xrootd
150 sudo apt install python3-pip
151 pip3 install awscli
152 pyenv --version
153 which pyenv
154 pip install pipenv
155 pip install --user pipenv
156 pipenv --version
157 pypenv --version
158 sudo apt install python3.9-venv
159 pypenv --version
160 python3.9 -m venv my_venv
161 source my_venv/bin/activate
162 pipenv --version
163 pyenv --version
164 sudo usermod --append --groups docker $USER
165 history
166 exit
167 pipenv run
168 invenio-cli --version
169 invenio-cli init rdm -c v9.1
170 cd my-site
171 ls -al
172 invenio-cli install
173 sudo apt install python3-dev
174 sudo apt-get install python-dev python3-dev
175 invenio-cli install
176 sudo apt-get install python3.9-dev
177 source my_venv/bin/activate
178 cd
179 source my_venv/bin/activate
180 cd my-site/
181 invenio-cli install
182 cd
183 history
184 pipenv shell
185 cd my-site/
186 invenio-cli install
187 invenio-cli services setup
188 invenio-cli packages lock
189 invenio-cli services setup
190 invenio-cli services setup
191 invenio-cli services setup --no-demo-data
192 invenio-cli services status
193 invenio-cli services statusdocker-compose --version
194 docker-compose --version

Hm okay. But did you try docker compose versionas well? I think this causes the issue.