InvenioRDM Alpha 8 (June Release)

We are happy to announce InvenioRDM Alpha 8 (June release).

What’s new?

The June release is a major backend development release which are, as a rule of thumb, not highly visible. We have developed three new modules that lay the foundations for the new core data flow of Invenio(RDM) and allow core and instance developers to work on and customize Invenio in an easier and cleaner way. In other words: better developer experience and customizability!

The primary focus for the release was:

  • Keep working on the migration from Bootstrap to SemanticUI
  • Several bug fixes and improvements on the frontend (mainly on deposit)
  • Develop new core modules for Invenio(RDM) backend.

UI Customizations are back! (except result records)**

You are able to customize your templates again! Sadly the JSX customizations are not functional yet, so the search page results are not customizable.

Visual appearance

The file previewer, the OAuth login and the settings pages are now migrated to SemanticUI!

There might still be some issues related to the visual appearance (e.g. the name of the previewed file is not in a panel as before, it will be soon). However, we have fixed a large amount of them and more will be fixed in the next Invenio Sprint on Semantic UI (happening at the end of August).

Creators, Contributors and Affiliations Identifiers

The Deposit page now accepts ORCID iDs for people (creators and contributors) and ROR identifiers for organizations (creators, contributors and affiliations). In each case an icon with a link to the respective entity on the record landing page reflects this connection.

Contributors are now correctly optional on the deposit page as well.

Python versions

There are now Invenio images for Python 3.7 and Python 3.8! This means that you can use Python 3.6, 3.7 and 3.8 for development and for containerize.

Backend and REST APIs

We have put a significant amount of work in refactoring some of the core API flow of Invenio, in order to address many of the issues that Invenio was facing in this domain. As a result 3 modules were born:

What do you need to do?

You can install the latest invenio-cli v0.14.2+, create a new instance and see how it looks like!

Install (TL;DR)

If you previously installed InvenioRDM, make sure you have the latest Docker image of your choice according to the Python version:

docker pull inveniosoftware/centos7-python:3.6
docker pull inveniosoftware/centos8-python:3.7
docker pull inveniosoftware/centos8-python:3.8

To install:

pip install invenio-cli --upgrade
invenio-cli init rdm
cd my-site
invenio-cli containerize --pre
invenio-cli demo --containers

To destroy the Python virtualenv, and remove the docker containers run:

cd my-site
pipenv --rm
docker-compose -f docker-compose.full.yml down


As always here is the template to give feedback:

## Bugs

## What worked well

## What didn't work well

## Wishes for documentation

Thank you for your patience, take care and stay safe!

1 Like

Comments so far:


for Invenio(RDM) APIs.

  • An experimental module to bridge the respresentational and data access worlds in Invenio. It hosts the business logic and might be merged back into invenio-resources.
    The links are broken, need to remove the : character.

–save button in deposits UI not working
–once the record is published record the metadata can not be edited
–default description of a record published is “remove me”, no description box found in the deposit UI

What worked well

Smooth deployment however this error was observed while the containers were deployed:
—> Running in 37b0af118eab

Installing dependencies from Pipfile.lock (e68f27)…
Failed to load paths: /bin/sh: /root/.local/share/virtualenvs/src–FJPeFkS/bin/python: No such file or directory

Failed to load paths: /bin/sh: /root/.local/share/virtualenvs/src–FJPeFkS/bin/python: No such file or directory
Failed to load paths: /bin/sh: /root/.local/share/virtualenvs/src–FJPeFkS/bin/python: No such file or directory

Wishes for documentation

documentation to install more packages require to add invenioRDM functionalities
For example, if you want to add oauth (GitHub) then you will need to install The contrib file itself use
cdvirtualenv src/invenio-oauthclient
pip install -e .[github]

So this will need to be documented in light of invenioRDM. i.e pipenv run pip install github?

Thanks a lot @cfgamboaI have edited the links and moving out the :. As for the deposit, the issues you encountered were there in the previous release. As in, at the moment one can only “publish” a record, and there is no notion of draft/deposit so the “save” option is not available. In addition, some fields (e.g. description are still hardcorded). My bad I did not mention this on the release, sorry about that :frowning:

As for the python error. Which python version are you using? We had that issue in the past with Python 3.6, and it has risen again in Python 3.7 (But pinning pipenv solve it). However, after the pin I did not experience it again. See for more information.

Thanks a lot for the feedback!

@ppanero python3.6 thank you for your feedback!

What worked well

BWT, I was able to Authenticate with GitHub.

1 Like


  • Running command

    • invenio-cli containerize --pre

    Gives error message

    • docker.errors.NotFound: 404 Client Error: Not Found (“No such container: b2share-invenio_web-ui_1”)

    This can be fixed by renaming the ui container to b2share-invenio_web-ui_1.

Hello @jussiste,

Could you tell us which is you Docker and Docker-Compose version? And what was the name the container had (before you changed it to fix it).

The issue is most likely on the logic we have implemented to generate that name (which depends on the Docker and Docker-Compose version).

Thanks in advance!

Thanks @cfgamboa , I re-opened the issue (We had fixed this for the previous release, not sure why it appeared again :frowning:

More info at:

My docker version is 19.03.12 and my docker-compose is version 1.23.1.

The container was named b2share-invenio-web-ui_1_ before renaming. So it followed the same naming conventions as the other containers. So basically I just removed the trailing number from the container.

The web-ui was the only container that caused this issue.

  • Jussi

@jussiste Thanks! Will crosscheck what happened and if I can reproduce the error :slight_smile: